How to export a Code Signing Certificate for Microsoft Authenticode certificate from Firefox

Solution ID:    SO21199    Updated:    06/14/2016

Solution

To export a Code Signing Certificate for Microsoft Authenticode from Firefox, perform the following steps:
Note: Symantec Code Signing Certificate for Microsoft Authenticode enrollment was migrated Oct 18, 2012 to a new system. Firefox browser can be used for certificate enrollment & installation.

  1. Open Firefox
  2. Cick Tools > Options > Advanced
  3. Click View Certificates
  4. Select Your Certificates
  5. Locate the Code Signing Certificate for Microsoft Authenticode and click on the entry
  6. Click Backup
  7. Select the location where the back-up file should be saved
  8. Provide a file name and click Save
    Note: There is no need to assign a file extension as the extension will be  .p12
  9. Provide a Password to protect the file and click Save
    Note: This Password will be requested when importing the back-up file
  10. The back-up file should now be created


Once the back-up file has been created, it can be used with theCode Signing Certificate for Microsoft Authenticode signing tools. Refer to INFO190
Note: Signing can take place with either the .p12 file or with the certifcate imported into Internet Explorer. For instructions on importing the certifciate into Internet Explorer, refer to the instructions below.

Import Code Signing Certificate for Microsoft Authenticode into the Microsoft Certificate Store using Internet Explorer
 
1.  Open Internet Explorer
2.  Click Tools > Internet Options > Content tab > Certificates > Import. The Certificate Wizard opens.
3.  Browse to the certificate you want to import
4.  Click Next
5.  Enter the password that was created during certificate export
6.  Click the checkbox Mark the key as exportable
7.  Select the option to Automatically select the certificate store based on the type of certificate
8.  Click Finish.
 

Contact Support

Find Answers